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บทที่ บทที่ 33  
ชุดคําส่ังในการชุดคําส่ังในการแกไขภาพแกไขภาพ  

3.1 การลบวัตถุดวยคําสั่ง ERASE 

Modify > Erase  

  

 
Erase ใชในการ ลบ วัตถุที่ไมตองการออกจากพืน้ที่วาดภาพ  
ขั้นตอนการใชคําสั่ง 

1. เลือกคําสั่ง 

2. เลือกชิ้นงาน 

3.  Enter 

Command: _erase 

Select objects: 1 found (เลือกวัตถุที่ตองการลบ) 

Select objects: (Enter)    
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 3.2 การคัดลอกวัตถุดวยคําสั่ง Copy 

Modify > Copy  

  

 

 
Copy ใชในการ คัดลอก วัตถุที่ตองการ  
ขั้นตอนการใชคําสั่ง 

1. เลือกคําสั่ง 
2. เลือกชิ้นงาน Enter 

3. กําหนดจุดอางอิงในการคัดลอก (Base point or 

displacement) 

4. กําหนดจุดใหมของการคัดลอก (Second point of 

displacement) 

Command: _copy 

Select objects: 1 found (เลือกวัตถุที่ตองการคัดลอก) 

Select objects: 

<Base point or displacement>/Multiple: (กําหนด
จุดอางอิงแรก) 
Second point of displacement: (กําหนดจุดอางอิงทีส่อง)    
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3.3 การคัดลอกวัตถุในลักษณะพลิกกลับดวยคําสั่ง Mirror 

Modify > Mirror  

  

 

 
Mirror ใชในการทําภาพสะทอน หรือ พลิก วัตถุที่

ตองการ  
ข้ันตอนการใชคําสั่ง 

1. เลือกคําสั่ง 
2. เลือกชิ้นงาน Enter 

( กําหนดเสนสะทอนการพลิกจุดแรก (First point of 

mirror line) 

( กําหนดเสนสะทอนการพลิกจุดที่สอง (Second point) 

( โปรแกรมจะถามวาตองการลบชิ้นงานตนแบบหรือไม 

(Delete old objects? <N> ) หากตองการลบ พิมพ Y  

Command: _mirror 

Select objects: Other corner: 3 found 

Select objects: 

First point of mirror line:  

(กําหนดจุดอางอิงแนวการพลิกแรก) 
Second point: (กําหนดจุดอางอิงแนวการพลิกที่สอง) 

Delete old objects? <N> (ตองการลบชิ้นงานตนแบบหรือไม)    
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ตนแบบ 

 

  
  Mirror แบบไมลบตนแบบ       Mirror แบบลบตนแบบ 
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3.4 การสรางเสนคูขนานดวยคําสั่ง Offset 

Modify > Offset  

  

 

 
Offset ใชในการสรางเสนคูขนานจากตนแบบโดยการ

กําหนดระยะหางระหวางตาํแหนงที่ตองการกับชิน้งานเดิม  

ข้ันตอนการใชคําสั่ง 

1. เลือกคําสั่ง 
2. กําหนดระยะ Offset (Offset distance or Through) 
3. เลือกชิ้นงาน 
4. กําหนดดานของการ Offset (ใช Mouse Click) Side 

to offset? 
5. เลือกชิ้นงานชิน้ตอไป 
6. หากไมมีชิ้นงานที่จะ Offset แลวใหกด Esc   

Command: _offset 

Offset distance or Through <1.0000>: 1 (กําหนดระยะการ 
Offset) 
Select object to offset: 

Side to offset? (กําหนดดานทีต่องการ Offset) 

Select object to offset: (เลือกชิ้นงานตอไป)    
 

  
Offset เสนตรง 

 

 



  บทที่ 3 : ชุดคําสั่งในการแกไขภาพ-RMUTL Chiangmai 

90 

  
Offset เสนโคง 

 

  
 

   
Offset รูปวัตถุ 
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3.5 การคัดลอกวัตถุหลายชิ้นดวยคําสั่ง Array 

Modify > Array  

  

 

 
Array ใชในการสรางสาํเนาชิ้นงาน (Copy) จากตนแบบ 

มี 2 แบบคือ 

Array แบบสี่เหลี่ยม (Array Rectangular) โดยการ

กําหนดจํานวนวัตถุในแนวนอน (Column) และแนวตั้ง 

(Row) ตลอดจนระยะหางของ Column และ Row 

Array แบบวงกลม (Array Polar) โดยการกําหนดจุด

ศูนยกลางของการทาํ Array แบบวงกลม และกําหนด

จํานวนของวัตถุที่ตองการทาํ Array รอบจุดศูนยกลาง

วงกลม  

ขั้นตอนการใชคําสั่ง [ Array แบบสี่เหลี่ยม ] 

1. เลือกคําสั่ง 
2. เลือกชิ้นงานทีจ่ะทํา Array กดปุม Enter 

3. เลือกออปชั่น Rectangle พิมพ R กดปุม Enter 

4. กําหนดจํานวนของชิน้งานดาน Column และ ดาน 

Row 

5. กําหนดระยะหางดาน Column และ ดาน Row   
Command: _array 

Select objects: 1 found (เลือกชิ้นงานที่ตองการ Array) 

Select objects: 

Rectangular or Polar array (<R>/P): R (เลือกตัวเลือก แบบ 
Rectangle) 
Number of rows (---) <1>: 2 (กําหนดจํานวนชิ้นงานแนวตั้ง) 

Number of columns (|||) <1>: 3 (กําหนดจํานวนชิ้นงานแนวนอน) 

Unit cell or distance between rows (---): 5 (กําหนดระยะหาง
แนวตั้ง) 
Distance between columns (|||): 5 (กําหนดระยะหางแนวนอน)    
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ขั้นตอนการใชคําสั่ง [ Array แบบวงกลม ] 

1. เลือกคําสั่ง 
2. เลือกชิ้นงานทีจ่ะทํา Array กดปุม Enter 

3. เลือกออปชั่น Polar พิมพ P กดปุม Enter 

4. กําหนดจุดศูนยกลางของการทํา Array แบบวงกลม {Base/<Specify center point of 

array>:} 

5. กําหนดจํานวนของชิน้งาน {Number of items} 

6. กําหนดมุมของการทํา Array ต้ังแต 0-360 องศา { Angle to fill (+=ccw, -=cw) 

<360>:} 

7. … กําหนดวาจะใหชิ้นงานตนแบบหมนุดวยหรือไม { Rotate objects as they are 

copied? <Y>} 
Command: _array 

Select objects: 1 found  (เลือกชิ้นงานที่ตองการ Array) 

Select objects: 

Rectangular or Polar array (<R>/P): P (กําหนดตัวเลือกเปนแบบ Polar) 

Base/<Specify center point of array>: (กําหนดจุดศูนยกลาง Array แบบวงกลม) 

Number of items: (กําหนดจาํนวนชิ้นงานทีต่องการ Array) 

Angle to fill (+=ccw, -=cw) <360>: (กําหนดมุมของการ Array แบบวงกลม) 

Rotate objects as they are copied? <Y> (กําหนดวาจะหมุนชิ้นงานตนแบบหรือไม) 
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3.6 การเคลื่อนยายวัตถุดวยคําสั่ง Move 

Modify > Move  

 

  

 

 
Move ใชในการ เคลื่อนยายชิ้นงาน จากจุดหนึง่ไปยังอกีจุด

หนึง่  

ข้ันตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกชิ้นงานที่จะ Move กดปุม Enter 
3. กําหนดจุดอางอิงในการเคลื่อนยาย {Base point or 

displacement:} 

( กําหนดจุดทีต่องการยาย หรือ ปอนคาระยะ {Second point 

of displacement:}  

Command: _move 

Select objects: (เลือกวัตถทุี่จะยาย) 

Select objects: (Enter) 

Base point or displacement: Second point of 

displacement: 

(กําหนดจุดอางอิงในการยายจุดแรกและจุดที่สอง 

หรือปอนคาระยะ)  
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3.7 การหมุนวัตถุดวยคําสั่ง Rotate 

Modify > Rotate  

  

 

 
Rotate ใชในการ หมุนชิ้นงาน ไปในมุมตางๆ ตามที่กาํหนด  

ข้ันตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกชิ้นงาน กดปุม Enter 

3. กําหนดจุดหมนุ {Base point:} 

4. กําหนดมุมที่ตองการหมนุ (ใช mouse Click หรือ 

ปอนคามุม) 
Command: _rotate 

Select objects: (เลือกวัตถุที่จะหมุน) 

Select objects: 

Base point: (กําหนดจุดหมุน) 

<Rotation angle>/Reference: (กําหนดมุมที่ตองการหมุน)    
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3.8 การเปลี่ยนขนาดวัตถุดวยคําสั่ง Scale 

Modify > Scale  

  

 

 
Scale ใชในการ ปรับขนาดของชิ้นงาน ใหมีขนาดใหญข้ึนหรือ

เล็กลง 

หากกําหนดคา = 1 จะมีขนาดเทาเดิม (1 เทา) 

หากกําหนดคา = 2 จะมีขนาดใหญข้ึน 2 เทา 

            หากกาํหนดคา = 0.5 จะมีขนาดเล็กลงครึ่งหนึง่  

ข้ันตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกชิ้นงาน กดปุม Enter 

3. กําหนดจุดหมนุอางอิงการ Scale {Base point:} 

4. กําหนดขนาดในการขยายหรือลดขนาด (ใช mouse 

ลาก หรือ ปอนคา Scale) 
Command: _scale 

Select objects: (เลือกวัตถุที่จะขยายหรือลดขนาด) 

Select objects: 

Base point: (กําหนดจุดอางองิ) 

<Scale factor>/Reference: (กําหนดคา Scale)    
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3.9 การดงึวัตถุใหยืดหรือหดดวยคําสั่ง Stretch 

Modify > Stretch  

  

 

 
Stretch ใชในการ ยืดหรือหด สวนใดสวนหนึ่งของชิ้นงานไป

ในทิศทางใดทศิทางหนึ่ง  

ข้ันตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกชิ้นงาน (ใช Mouse Click 

ดานมุมขวาลางของสวนที่จะยืดแลว Click 

จุดมุมซายบน แบบ cross-window) กดปุม Enter  

3. ( กําหนดจุดหมุนอางอิงการ Stretch {Base point or 

displacement:} 

4. ( กําหนดจุดยดืจุดที่สอง (ระยะยืด) {Second point 

of displacement:} 

Command: _stretch 

Select objects to stretch by crossing-window or 

crossing-polygon... 

Select objects:  

Select objects: 

Base point or displacement: 

Second point of displacement:  
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3.10 การเพิ่มหรือลดความยาวของเสนดวยคําสั่ง Lenghten 

Modify > Lenghten  

  

 

 
Lengthen ใชในการ กําหนดคาความยาวใหกับเสนตรง  

มี 4 ตัวเลือก คือ  

Delta             กําหนดคาเพิ่มจากคาความยาวเดมิ 

Percent กําหนดคาเปนเปอรเซนต 

Total             กําหนดคาความยาวทั้งหมด 

Dynamic กําหนดคาความยาวโดยใช Mouse Click  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกตัวเลือกที่ตองการ 
3. เลือกชิ้นงานดานใดดานหนึ่ง 

Command: _lengthen 

DElta/Percent/Total/DYnamic/<Select object>: 

Current length: 5.0000 (คาควาวยาวของเสนเดิม) (อาจจะแสดง
หรืออาจไมแสดงก็ได) 
DElta/Percent/Total/DYnamic/<Select object>: T (เลือกตัวเลือก 
Total) 
Angle/<Enter total length (1.0000)>: 15 (ปอนคาขนาดความยาว
ของเสนตรง)    
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3.11 การตัดเสนดวยคําสั่ง Trim 

Modify > Trim  

  

 

 
Trim ใชในการ ตัดชิ้นงานในสวนที่ไมตองการจากแนวขอบตัด

ที่กําหนด (Cutting Edge)  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกชิ้นงานทีต่องการ หรือเลือกเสนแนวขอบตัด 

3. เลือกสวนของชิ้นงานดานทีต่องการ ตัด 
Command: _trim 

Select cutting edges: (Projmode = UCS, Edgemode = No 

extend)  (เลือกแนวเสนขอบตัด) 

Select objects: 1 found 

Select objects: 

<Select object to trim>/Project/Edge/Undo: (เลือกเสนที่ตองการ
ตัด) 
<Select object to trim>/Project/Edge/Undo:    
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3.12 การตอเสนดวยคําสั่ง Extend 

Modify > Extend  

  

 

 
Extend ใชในการ ตอชิ้นงานใหยาวไปยงัขอบเขต (Bound 

Edge) ที่กําหนด  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกแนวขอบเขตที่ตองการตอเสนไปชน (Bound 

Edge) 

3. เลือกปลายเสนที่ตองการตอใหยาวไปชนแนวขอบเขต 
Command: _extend 

Select boundary edges: (Projmode = UCS, Edgemode = No 

extend) 
(เลือกแนวขอบเขตการตอเสน) 
Select objects: 1 found 

Select objects: 

<Select object to extend>/Project/Edge/Undo: (เลือกปลายเสน
ที่ตองการตอ) 
<Select object to extend>/Project/Edge/Undo:    
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3.13 การตัดเสนดวยคําสั่ง Break 

Modify > Break  

  

 

 
Break ใชในการ ตัดช้ินสวนของชิ้นงานที่ไมตองการ 

ไมวาจะเปนเสนตรง สวนโคง วงกลม หรือ รูปเหลีย่ม  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกตําแหนงแรกที่ตองการตัด 

3. เลือกตําแหนงที่สอง คือระยะการตัด 
Command: _break  

Select object: (กําหนดจุดแรกในการตัด) 

Enter second point (or F for first point): (กําหนดจุดที่สองในการ
ตัด)    
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3.14 การสรางมุมตัดดวยคําสั่ง Chamfer 

Modify > Chamfer  

  

 

 
Chamfer ใชในการ ปาดมุมของชิ้นงาน เสนตรงสองเสนที่

ตัดกัน หรือ บริเวณมุมของรปูเหลี่ยม โดยการกําหนดคาระยะ

มุมทัง้ 2 ดาน (Distance) หรือ กําหนดคาระยะกับมมุ 

(Angle) หรือ การขลิบ (Trim) เปนตน  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกตัวเลือกในการปาดมุม 

3. เลือกคําสั่งใหม 
4. เลือกเสนที่ตองการทําปาดมมุ 2 เสน เสนแรก , เสนที่

สอง 
Command: _chamfer 

(TRIM mode) Current chamfer Length = 11.6323, Angle = 304 

Polyline/Distance/Angle/Trim/Method/<Select first line>: d 
(กําหนด Distance) 
Enter first chamfer distance <10.0000>: 3 

Enter second chamfer distance <3.0000>: 

 

Command:  CHAMFER 

(TRIM mode) Current chamfer Dist1 = 3.0000, Dist2 = 3.0000 

Polyline/Distance/Angle/Trim/Method/<Select first line>: (เลือก
เสนแรก) 
Select second line: (เลือกเสนที่สอง)    
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3.15 การสรางมุมมนดวยคําสั่ง Fillet 

Modify > Fillet  

  

 

 
Fillet ใชในการ ทํามุมมนของชิ้นงาน เสนตรงสองเสนที่ตัด

กัน หรือ บริเวณมุมของรูปเหล่ียม โดยการกําหนดคารัศมีของ

การทาํมุมมน  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2. เลือกตัวเลือกในการทํามมุมน (รัศมีของมุมมน) 

3. เลือกคําสั่งใหม 
4. เลือกเสนที่ตองการทําปาดมมุ 2 เสน เสนแรก , เสนที่

สอง 
Command: _fillet 

(TRIM mode) Current fillet radius = 10.0000 

Polyline/Radius/Trim/<Select first object>: R (กําหนดรัศมีของ
มุมมน) 
Enter fillet radius <10.0000>: 3 (คารัศมีมุมมน) 

 

Command:  FILLET 

(TRIM mode) Current fillet radius = 3.0000 

Polyline/Radius/Trim/<Select first object>: (เลือกเสนแรก) 

Select second object: (เลือกเสนที่สอง)    
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3.16 การระเบิดวัตถุดวยคําสั่ง Explode 

Modify > Explode  

  

 

 
Explode ใชในการ ระเบิดชิ้นงานที่เปนชิ้นเดียวกนั หรือกลุม

กอนออกเปนสวนๆ เชน Polyline , Donut , Rectangle หรือ 

Block  

ขั้นตอนการใชคําสั่ง  

1. เลือกคําสั่ง 
2.  เลือกวัตถทุี่ตองการระเบิด   
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3.17 การใชกริ๊บส (Grips) 
 ใชในการปรับแตงวัตถุใดๆ บนพืน้ทีว่าดภาพ  

 กร๊ิบส (Grips) คือ จุดส่ีเหลีย่มจัตุรัสเล็กๆ  โดยปกติจะมสีีน้ําเงิน จะปรากฏเมื่อเราใชเคอร

เซอร Click บนวัตถุชิน้นั้น โดยมิไดเลือกคําสั่งใดๆ  

 เราสามารถใชกร๊ิบส ชวยในการ ยึด (Stretch)  , การเคลือ่นยาย (Move) , การหมนุ (Rotate) , 

การพลิกกลับ (Mirror) หรือเปลี่ยนขนาด (Scale)  

 วัตถุแตละชิ้นจะมีจํานวน Grips ที่แตกตางกัน 

 
 การปรับแตงวตัถุโดยการใช Grips นัน้ตองทําการเลือกจดุ Grips โดยปกติจุด Grips จะเปนสี

น้ําเงินเรียกวา Warm grips ถาเราเอา mouse ไป Click บนปุม Grips จะเปลี่ยนสีเปนสีแดง เรียกวา 

Hot Grips ซ ึ่งใชในการปรับแตงวัตถ ุ

 บนบรรทัดปอนคําสั่งจะปรากฏขอความ 

** STRETCH ** 

<Stretch to point>/Base point/Copy/Undo/eXit: 

 ทุกครั้งที่เรากดปุม Enter จะเปลี่ยนคาํสั่งเปน Move , Rotate , Scale , Mirror ตามลําดับและ

วนกลับมาที่เดิม 

 หากบรรทัดปอนคําสั่งแสดงคําสั่งใดโปรแกรมก็จะรับคําสั่งนัน้ไปแกไขวัตถ ุ
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 อีกวิธหีนึง่ในการเรียกใชคําสัง่จากจุด Grips คือการเลือกจุด Grips ใหเปน Hot Grips แลว 

Click mouse ปุมขวา จะเกดิเคอรเซอรเมนูใหเราเลือกคาํสั่งดังรูป 

 
 โดยจุดที่เลือกนั้นจะเปนจุดอางอิงจุดฐานในการแกไขรูป  

เมนู Tools> Option… ใชในการแกไขสีของ Grips และ

ขนาดของ Grips ในแท็บหมวด Selection 
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